• 注册
    • 查看作者
    • [wenyan-Lang]用文言文写程序你听过没?

       大家好这里是苏惟澄哦

      今天是遇唐系统更新完成的日子呢

      发个帖子来纪念一下啦

      好了废话不多说直接进入今天的主题

      --用文言文来编程--

      最近惟澄在世界最大程序员社区乱转时发现了一个挺有意思的编程语言

      wenyan-lang 文言文语言

      那么先贴一串代码来看看吧

      [wenyan-Lang]用文言文写程序你听过没?

      “欸?惟澄你给我们读古文干嘛呀!!耍我们是不??”

      欸欸欸,先别急躁呀

      这真的是代码哦!!

      这就是LingDong大佬开发出来的文言文语言!!

      咱们来深入研究吧。

      我们先搞一个示例过来

      吾有一數。曰三。名之曰「甲」。
      為是「甲」遍。
      	吾有一言。曰「「問天地好在。」」。書之。
      云云。

      “呜呜,惟澄,我看不懂呀。。。”

      不要紧嘛

      听惟澄给你详细地讲咯

      先来看一下转换出来的JavaScript

      也就是“正常一点”的代码

      var n = 3;
      for (var i = 0; i < n; i++) 
      {	
          console.log("問天地好在。");
      }

      嗯嗯,现在看懂了吧?

      “看不懂。”

      小傻瓜,惟澄再来给你讲。

      (如果你已经是惟澄这样的程序员了,自己跳过吧)

      先从JavaScript代码开始吧

      首先看这个

      var n = 3;

      它的意思呢,就是设一个变量,数值是3

      就像是我们方程里的未知数

      也就是设一个未知数n=3

      for (var i = 0; i < n; i++)

      这个呢,就是要求花括号内的代码要循环运行之前设的未知数数值次数咯

      console.log("問天地好在。");

      这个就是输出引号内的话。

      现在再让我们看回文言文:

      吾有一數。曰三。名之曰「甲」。

      意思就是

      “我有一个数字,这个数字的值是三,这个数字的名字叫做‘甲’”

      為是「甲」遍。

      “把本句后,‘云云’前的内容运行‘甲’遍”

      那么”云云“什么意思我也不解释咯,也就是充当括号的作用。

      所以程序运行出来结果就是这样啦:

      問天地好在。
      問天地好在。
      問天地好在。

      可能有些晦涩难懂,不过...应该听懂了吧(摸摸头)

      那么这就是神奇的文言文语言啦!

      惟澄最崇拜张岱啦

      就写一个文言文程序,大家看看能不能看懂吧!

      吾有一言。曰「「已至湖心亭」」。書之。   
      有數三。名之曰「酒數」。   
      恆為是。若「酒數」等於零者乃止也。   
      	吾有一言。  
      		曰「「余强饮一大白。」」。書之。   
      減「酒數」以一。昔之「酒數」者。今其是矣云云。   
      吾有一言。曰「「莫说相公痴,更有痴似相公者。」」。書之。

      运行结果就是这样

      已至湖心亭
      余强饮一大白。
      余强饮一大白。
      余强饮一大白。
      莫说相公痴,更有痴似相公者。

      那么今天的文章就写到这

      我们下次再见咯!!!

      wenyan-lang源地址:https://github.com/LingDong-/wenyan-lang

      江苏·南通
    • 4
    • 4
    • 0
    • 181
    • 苏惟澄少多momomoKtm

      请登录之后再进行评论

      登录
    • 1
      少多LV.1
      打赏了10啧币。
    • 1
      少多LV.1
      这个帖子计算机方面的技术含量还是可以的
      [s-85] 我眼前一亮~
    • 1
      KtmLV.6大会员精神小伙
      支持一下,可惜现在汉语都难
    • 1
      KtmLV.6大会员精神小伙
      打赏了10啧币。
    • 实时动态
    • 返回顶部
    • 发表内容
    • 做任务
    • 到底部